Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
error when trying to launch

i do believe i have installed the game and all the bits correctly but i keep getting this error when i try to launch the game

Attached Files Thumbnail(s)
have you installed updates?? my only way to play it is installing 1.10, 1.20 and 1.42 patchs you can look for Black and white complete collection, better than old versions

There is a little problem with permissions too, you have to do some things for totally working save games and more:

1- Go to "C:\Program Files (x86)" Right click to "Lionhead Studios Ltd" folder and Propeties
2- Go to security tab, Edit and allow all permissions, apply and acept.( important permisssion "CREATORS OWNER")
3- You have to do the same whit "Black and White" inside and "Profiles" folder inside.
4- you can find your old game save in:
C:\Users\"USER"\AppData\Local\VirtualStore\Program Files (x86)\Lionhead Studios Ltd\Black and White\Profiles
You seem to be using crack for 1.00. You need to use the correct crack.

And about "1.42", it contains fixes stolen from our patch without giving us any credit. Advertising it is not allowed.
Im sorry so much i did't know that Lant... Sorry...
thanks for the help, the error is gone but now the game just crashes immediately, what i did was applied the new crack then repatched it with 2.0 patch, im gonna try to reinstall from scratch with this new info and see what happens.

Edit: ok i reinstalled and applied all the patches 1.1, 1.2, and 1.3, then applied the correct nocd crack for 1.3, then applied the 2.0 patch, then dragged all the music files into the sounds folder, i even ejected the iso file to make sure it wasnt trying to read the disk, but to no avail, all i get is what looks like a application window pop up totally clack screen then it crashes to desktop with no error, also i will add the updated folder contents pic

Attached Files Thumbnail(s)
(08-19-2021, 21:19)Lant Wrote: You seem to be using crack for 1.00. You need to use the correct crack.

And about "1.42", it contains fixes stolen from our patch without giving us any credit. Advertising it is not allowed.

Where was a Advertising? I don't see any advertisings.
Installing 1.10 and 1.20 before installing 1.30 is not necessary.

What BaW Patch 2.0 fixes is not related to crashes, so it is not relevant to the problem.
Music files aren't relevant either.
Launching the game as an administrator is not necessary for the game to work. It's important for fixing issues with saves. Again, not relevant.
There's no need to do anything about these things when reinstalling to try to get the game to simply launch. But none of them should cause the issue.

Things seem good when looking at the screenshot and the game should work. That's strange.
runblack.exe has a shield, p5dll.dll is present and has correct size (though a strange date), BaW Patch 2.0 is applied.

You have readme-UK.txt file. It's unusual. Its date and size seem to be the same as of the readme for 1.10.
Perhaps it could be related to the issue? What made it appear? Maybe you got a strange iso and something else is unusual in it? But maybe it's simply installed with 1.10 and I don't remember it because I install 1.30 on 1.00. Maybe it's not strange in that case.

The screenshot doesn't show if you are using compatibility mode, which you shouldn't use. It's worth a try enabling it for one time, though. The game should launch anyway, though.
It is unlikely, but the problem may be with the registry. It may point to a profile that doesn't exist, though that shouldn't be a problem if you never played the game. Click Start, type "regedit", check what's in HKEY_CURRENT_USER\Software\Lionhead Studios Ltd\Black & White. Especially "LHMultiplayer" and its "Profile" value. Compare with the contents of your "Profiles" directory. Though even if the whole registry key is deleted or renamed the game should still launch, even if it won't work perfectly.

Which resolution are you using in the game?

It's worth a try using different game version, too. 1.10 fixes a lot of things, so start with it. Reinstall the game or uninstall the patches, install 1.10 and a crack. If it won't work, try 1.00 and 1.20, too, with correct cracks. To make it faster, don't apply BaW Patch 2.0.
this might be too many hoops for me to jump through at the moment, i love the game and a good nostalgia trip would be really nice rite now, i might have to wait for a easier way to make this work
At least try a different game version.
ok, so i tried every permutation and combination of all the different versions, cracks and suck and nothing worked, im not sure, its bummed me out, should i try to find a different iso, i got mine from myabandonware website if you are aware of a better version id love to know, i purchased this game 20 years ago and i still have the jewel case but the cds are crazy scratched

Forum Jump:

Users browsing this thread: 1 Guest(s)